Kelly's Twits

Print This Post Print This Post

Ultimate Tag Warrior, Ecto, and other fun things

I have become increasingly intrigued with the concept of “tagging” in blogs over the past year or so. Tagging is a way for someone posting a blog entry (or other web content) to include some sort of categorization hints in the form of keywords. Specialized search engines like Technorati can then use those keywords to present “similar” content.

Over the last 24 hours I’ve been trying to set up a “local” (I.E.: on my server) tag structure. As my base I used Ultimate Tag Warrior (UTW) for WordPress. I then added some things:

Getting Ecto 1.8.8 for Windows to work with UTW

Robin’s hack (part 1), as I understand it, basically relies on the function of a feature in Ecto which supports embedding tags as keywords instead of within the “normal” body of the HTML. I imagine this works great in the Macintosh version of Ecto- in the Windows version, it doesn’t quite work. Ecto still includes all of the HTML comments and such along with the tags when you choose the “Keywords” option, so you end up with tags that look like:

<a href="http://www.technorati.com/tag/lawyers" rel="tag">lawyers</a>

Not exactly what is wanted, when the real keyword in the above line is “lawyers”.

To fix this, I added a simple little function to xmlrpc.php that fixes 90% of the problem:

/* Kelly Adams UTW/Ecto hack clean Ecto keywords */
function ecto_clean_tags($tagset) {
        /* strip html tags */
        $clean_tags = strip_tags($tagset);
        return ($clean_tags);
}

I added this immediately before Robin’s “ecto_get_keywords” function. I then “wrapped” each $POST assignment from Robin’s hack with this function like this:

          // ROBIN LU UTW / ECTO HACK
          $_POST['tagset'] = ecto_clean_tags($content_struct['mt_keywords']);

The last 10% of fixing this for me was to change the settings in ecto slightly.

I’m still not all the way there- I want to experiment with a tag cloud or something similar- hopefully I’ll have that up soon.

Be Sociable, Share!

5 comments to Ultimate Tag Warrior, Ecto, and other fun things

  • [...] Posted by Kelly Adams on May 23rd, 2006  I mentioned previously that I had installed on my site.  In that posting, I implied that I had Ecto for Windows working with UTW.  The truth is, it only seemed to be working- in reality, Ecto was creating tags that UTW could work with, but it wasn’t able to read them back in for editing purposes.  It’s been a bit of a struggle getting it to work… [...]

  • Cube Guy

    How did you get the permalinks to work in the tiga theme? I just started working WP, and you seem to have it working like a charm. When I use it, I lose all CSS style. I just want date and post name…Please help :)

  • Greetings, Cube Guy!

    It has been a while since I did my basic WordPress setup, and permalinks were one of the first things I configured. So I may be rather sketchy on my details here: as I recall, there wasn’t anything “magical” I had to do: in the WordPress Admin panel, Permalinks page, I chose the “Date and name based” option under the “Common options” choice; and I edited the .htaccess file in my blog’s home directory. The changes to .htaccess were to add some rewrite rules for the URLs: if you look at the same page in the admin panel where you set the permalink options, you’ll see the settings that need to be included.

    Note, however, that if your HTTP server (E.G.: Apache) isn’t configured to permit configuration overrides (E.G.: AllowOverrides All), then the content of the .htaccess file may not be processed.

    Hopefully this points you in the right direction!

  • Cube Guy

    Hmmm. The permalinks change for me, I just seem to lose all CSS style of the Tiga theme. i.e The page loses all the colors and text fonts, but all is there…Any ideas…Sorry to be a pest and stretching your memory. I have looked elsewhere, and searched, but you seem to be the only person who has gotten it to work. When I get it working, I will be more than happy to blogroll you for all your help :)

  • Well, for starters I’m using a self-modified version of the WP-Andreas09 theme, not the Tiga theme. Mind you, I had to check and see what theme I was using before I said that :)

    Another consideration: I’m not sure that the Tiga theme is necessarily updated to support the most recent versions of WordPress (I’m using 2.1.2). You might what to check out the Tiga author’s website. The last update I see there for the Tiga theme, version 1.0.2, is early 2006. If you go to that previous link you’ll see that the author has included some frequently asked questions and special guidance for using the Tiga theme.

    One of the downsides to using other themes and plugins than those that are included by default with WordPress is that it means you have to keep up with more than just WordPress updates. Each plugin and custom theme also has it’s own quirks and update issues to deal with. Fun stuff to keep us on our toes, I guess!

Leave a Reply

  

  

  

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>